Solved: VCS WARNING V-16-1-50104 Command failed. At least Group Operator privilege required.

Many of the times we observe below error message while running some VCS command from some user.

Error Message

ngeuser@ngeaix001> hagrp -clear vxfen -sys ngeaix001
VCS WARNING V-16-1-50104 Command (hagrp -clear vxfen  ngeaix001 ) failed. At least Group Operator privilege required
ngeuser@ngeaix001>

 

Solution
To solve this issue first check the output of the users registered to run veritas command.

1. Check user list authorized to run VCS Commands.

ngeuser@ngeaix001> hauser -display
ngeuser:
GroupOperator for group(s) ( interfaces_mount, ngeuser_adminserver, ngeuserdomain_mount )

 

2. Now check out the available service groups on system.

ngeuser@ngeaix001> hastatus -summ

 

3. Add new service group vxfen access to this user.

ngeuser@ngeaix001> hauser -addpriv ngeuser Operator -group vxfen 

 

4. Now check the added privilege with user.

ngeuser@ngeaix001> hauser -display
ngeuser:
GroupOperator for group(s) ( interfaces_mount, ngeuser_adminserver, ngeuserdomain_mount, vxfen )

Leave a Reply

Your email address will not be published.