AIX: How to get top 15 Processes using high swap usage.

Today we will look a small however useful tip to see swap usage in AIX.

Here we will also check the top 15 processes sing high swap space on the server.

It is very useful in day to day server monitoring.

1. Checking total swap usage summary.

ngelinux120:tmp $ lsps -a
Page Space      Physical Volume   Volume Group    Size %Used Active  Auto  Type Chksum
hd6             hdisk9            rootvg       16384MB     0   yes   yes    lv     0

 

2. Checking detailed swap/memory usage

ngelinux120:tmp $ svmon
               size       inuse        free         pin     virtual   mmode
memory     19660800    13930592     5730208     3501431     8580805     Ded
pg space    4194304       20042

               work        pers        clnt       other
pin         2819304           0        4543      677584
in use      8580805           0     5349787

PageSize   PoolSize       inuse        pgsp         pin     virtual
s    4 KB         -     6671232       20042     1074151     1321445
m   64 KB         -      453710           0      151705      453710
L   16 MB         -           0           0           0           0
S   16 GB         -           0           0           0           0

 

3. Get top 15 processes using high swap space.

ngelinux120:tmp $ svmon -Pt15 | perl -e 'while(<>) {print if($.==2||$&&&!$s++);$.=0 if(/^-+$/)}'
-------------------------------------------------------------------------------
     Pid Command          Inuse      Pin     Pgsp  Virtual 64-bit Mthrd  16MB
14614634 java            937119    14475        0   694594      Y     Y     N
20381732 java            934507    14472        0   798633      Y     Y     N
24641774 java            885806    14476        0   749949      Y     Y     N
19267814 java            859320    14474        0   751692      Y     Y     N
20250662 java            833321    14469        0   725423      Y     Y     N
25755864 java            804603    14475        0   698337      Y     Y     N
23527568 java            779297    14449        0   671909      Y     Y     N
22544386 java            237275    14382        0   192108      Y     Y     N
22085760 java            161927    14325        0   114979      Y     Y     N
20643848 httpd           128164    16547        0    89934      Y     Y     N
25362610 httpd            87394    14144        0    49164      Y     N     N
24969390 httpd            87329    14144        0    49183      Y     N     N
24838378 httpd            87324    14144        0    49094      Y     N     N
 8126716 syslogd          74817    14144        0    49183      Y     N     N
 9961618 had              71636    32579        0    45762      N     Y     N
ngelinux120:tmp $
0 0 votes
Article Rating
Subscribe
Notify of
guest

0 Comments
Newest
Oldest Most Voted
Inline Feedbacks
View all comments